IFunctionsSetVar Method

Assigns a value to the named variable using the Tedds 'SetVar' function. For information on Tedds calculation functions, use Tedds for Word and refer to the Tedds engineering library index at "Writing your own custom calculations\Calculation writing documentation\Tedds functions"

Namespace:  Tekla.Structural.InteropAssemblies.TeddsCalc
Assembly:  Tedds.TeddsCalcIA (in Tedds.TeddsCalcIA.dll) Version: 25.0.0.0
Syntax
ICalcValue SetVar(
	string name,
	Object value,
	string units = "",
	string attributes = ""
)

Parameters

name
Type: SystemString
Name of the variable
value
Type: SystemObject
Value to assign
units (Optional)
Type: SystemString
Units of the assigned value, only applicable if the value is numeric.
attributes (Optional)
Type: SystemString
Variable attribute flags (h = hidden, t = temporary, e = expression, r = readonly)

Return Value

Type: ICalcValue
Actual value of variable
See Also