ICalculatorExEventsUndefinedVariable Method

Undefined variable event

Namespace:  Tekla.Structural.InteropAssemblies.TeddsCalc
Assembly:  Tedds.TeddsCalcIA (in Tedds.TeddsCalcIA.dll) Version: 25.0.0.0
Syntax
void UndefinedVariable(
	string variableName,
	out string value
)

Parameters

variableName
Type: SystemString
Name of undefined variable
value
Type: SystemString
Value to be assigned to variable
Remarks
The undefined variable event can be used to provide a hook into the data model or API of another software system. If a variable is referred to in your calculations which doesn't exist then your event handler will be called and you have the opportunity to provide a value for the referenced name. Note that once a value has been provided the variable will then exist in Tedds so the undefined event will not fire again for that variable unless it is explicitly deleted.
See Also