ICalculatorGetVariables Method

Returns all the variables defined in the calculator excluding temporary variables

Namespace:  Tekla.Structural.InteropAssemblies.TeddsCalc
Assembly:  Tedds.TeddsCalcIA (in Tedds.TeddsCalcIA.dll) Version: 25.0.0.0
Syntax
string GetVariables(
	VariableFormat format = VariableFormat.Xml
)

Parameters

format (Optional)
Type: Tekla.Structural.InteropAssemblies.TeddsCalcVariableFormat
Format in which to return the variables, the default is XML

Return Value

Type: String
A string which defines the variables and their associated values and attributes. Temporary variables are excluded, if you require the temporary variables use GetVariables2
See Also