ITeddsDocument Interface |
Interface for an open Document
Namespace: Tekla.Structural.InteropAssemblies.Tedds
Assembly: Tedds.TeddsIA (in Tedds.TeddsIA.dll) Version: 25.0.0.0

The ITeddsDocument type exposes the following members.

Name | Description | |
---|---|---|
![]() | BimObjectId |
Returns a BIM object identifier associated with the document
|
![]() | CalcItem |
Returns a CalcItem object which represents the calculation associated with the document
|
![]() | FullName |
Returns the document full path and file name
|
![]() | Name |
Returns the documents name (excluding file extension)
|
![]() | Path |
Return documents file path (excluding file name)
|
![]() | Saved |
Saved status of document
|
![]() | VariablesXml |
Variables defined in the document in the Tedds XML schema format
|

Name | Description | |
---|---|---|
![]() | Activate |
Activate this document
|
![]() | Calculate |
Calculate document
|
![]() | Calculate2 |
Calculate the document and return the calculation status code
|
![]() | Close |
Close the document
|
![]() | Save |
Save changes to the document
|
![]() | SaveAs |
Save document to a new file location
|
![]() | SaveAsPdf |
Save the document in Adobe PDF format
|