IProjectItems Interface

Interface for a collection of Project items

Namespace:  Tekla.Structural.InteropAssemblies.Tedds
Assembly:  Tedds.TeddsIA (in Tedds.TeddsIA.dll) Version: 25.0.0.0
Syntax
public interface IProjectItems : IEnumerable

The IProjectItems type exposes the following members.

Properties
  NameDescription
Public propertyCount
Return the number of items in the collection
Public propertyItem
Returns a single item in the collection
Top
Methods
  NameDescription
Public methodAddDocument
Add an existing open document to the end of the collection of project items
Public methodAddFile
Add a reference to a Tedds document file to the end of the collection of project items
Public methodAddFolder
Add a new folder to the end of the collection of project items
Public methodAddFromPath
Add a single Tedds project file or a complete folder hierarchy from a full file path
Public methodGetEnumerator
Enumeration interface for iterating the items in the collection
Public methodRemove
Remove a project item from the collection
Top
See Also