Tekla.Structural.InteropAssemblies.Tedds Namespace

Tekla Tedds Application API

The Tedds Application API allows you to automate tasks using the features of the Tedds Application. For example you can create a project, add new documents, calculate those documents and convert final output documentation to PDF format. You cannot directly provide input variables to a calculation using just the Tedds Application. However by using the Tedds Calculator you can generate input variables and pre-calculated output which can then be used with the Tedds Application to create Tedds documents.

The Tedds Application is an Out-of-process COM Server Tedds.exe which means it can be used from both 32-bit and 64-bit processes.

The Tekla.Structural.InteropAssemblies.Tedds namespace contains the classes and types required to use the Tedds Application API.

Interfaces
  InterfaceDescription
Public interface_IApplicationEvents
Interface for Tedds application events
Public interfaceIApplication
Interface for the Main application
Public interfaceIBimProject
BIM project
Public interfaceILibraryCalcItem
Interface for a library calc item
Public interfaceIProjectFileItem
Interface for a project file item
Public interfaceIProjectFolderItem
Interface for a project folder
Public interfaceIProjectItem
Interface for a project item
Public interfaceIProjectItems
Interface for a collection of Project items
Public interfaceITeddsDocument
Interface for an open Document
Public interfaceITeddsDocuments
Interface for a collection of open documents
Public interfaceITeddsProject
Interface for a project
Enumerations
  EnumerationDescription
Public enumerationTdsCalcStatus
Calculation status
Public enumerationTdsProjectSavePdf
Save project to PDF options
Public enumerationTdsSaveOptions
File save options
Public enumerationTdsWindowState
Window state