ICalculatorExEventsCalculatingError Method

Calculating error event

Namespace:  Tekla.Structural.InteropAssemblies.TeddsCalc
Assembly:  Tedds.TeddsCalcIA (in Tedds.TeddsCalcIA.dll) Version: 24.1.0.0
Syntax
void CalculatingError(
	CalcErrorType errorType,
	uint errorCode,
	string context,
	string message,
	string expression,
	uint options,
	out CalcStatus status
)

Parameters

errorType
Type: Tekla.Structural.InteropAssemblies.TeddsCalcCalcErrorType
Type of error
errorCode
Type: SystemUInt32
Error code identifier
context
Type: SystemString
Context of error
message
Type: SystemString
Error message
expression
Type: SystemString
Expression which caused error
options
Type: SystemUInt32
Error handler option flags
status
Type: Tekla.Structural.InteropAssemblies.TeddsCalcCalcStatus
Calculation status, to stop calculation process return Aborted or Interrupted
See Also