RequirementAttribute Class |
Requirements can be placed on input parameters by using the Requirement Attribute.
These requirements will be evaluated before the method is called and if a requirement fails the method call will fail.

Namespace: Tekla.Structural.ExpressoAddIn
Assembly: Tedds.ExprInterop (in Tedds.ExprInterop.dll) Version: 24.1.0.0


Name | Description | |
---|---|---|
![]() | RequirementAttribute(String, Char) |
Place a requirement on a string input parameter
|
![]() | RequirementAttribute(String, Requirement) |
Place a requirement on a numeric input parameter
|
![]() | RequirementAttribute(String, Double, Double) |
Place a requirement on a numeric input parameter
|