Tekla.Structural.ExpressoAddIn Namespace |
Tekla Tedds Add-In's
Tedds Add-In's allow anyone with Microsoft .Net programming experience to extend the Tedds function library with their own custom functions. Creating an Add-In allows you to integrate Tedds with your existing in-house software applications or applications and services from other 3rd parties.
The Tekla.Structural.ExpressoAddIn namespace contains the classes and types required to create a Tedds Add-In

Class | Description | |
---|---|---|
![]() | AliasAttribute |
Register method with Tedds with an additional name
|
![]() | RequirementAttribute |
Requirements can be placed on input parameters by using the Requirement Attribute.
These requirements will be evaluated before the method is called and if a requirement fails the method call will fail.
|
![]() | UnitsAttribute |
Because Tedds calculations are ‘dimensionally aware’ Add-In methods must specify the units of each argument, and the units of any return value.
This is done using the Units Attribute.
|
![]() | ValidTypesAttribute |
Valid types to allow within a dynamic/object parameter
|

Enumeration | Description | |
---|---|---|
![]() | Requirement |
Requirement placed on numeric parameter via the Requirement Attribute |