IFunctionsSetVarExpr Method

Assigns an expression value to the named variable using the Tedds 'SetVar' function. For information on Tedds calculation functions, use Tedds for Word and refer to the Tedds engineering library index at "Writing your own custom calculations\Calculation writing documentation\Tedds functions"

Namespace:  Tekla.Structural.InteropAssemblies.TeddsCalc
Assembly:  Tedds.TeddsCalcIA (in Tedds.TeddsCalcIA.dll) Version: 25.0.0.0
Syntax
ICalcValue SetVarExpr(
	string name,
	string value,
	string attributes = "e"
)

Parameters

name
Type: SystemString
Name of the variable
value
Type: SystemString
Expression to assign
attributes (Optional)
Type: SystemString
attributes Variable attribute flags (h = hidden, t = temporary, e = expression, r = readonly)

Return Value

Type: ICalcValue
numerical error code
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next