ICalcValue Interface

Interface for an ICalcValue, the fundamental data type used by the calculator for input and output values

Namespace:  Tekla.Structural.InteropAssemblies.TeddsCalc
Assembly:  Tedds.TeddsCalcIA (in Tedds.TeddsCalcIA.dll) Version: 25.0.0.0
Syntax
public interface ICalcValue

The ICalcValue type exposes the following members.

Properties
  NameDescription
Public propertyDegrees
Returns the linear degrees dimension of the object. Only applicable for objects of type Number.
Public propertyIsDimensionless
Returns whether the units of a numeric object has dimensions. Only applicable for objects of type Number.
Public propertyLength
Returns the length dimension of the object. Only applicable for objects of type Number.
Public propertyMass
Returns the mass dimension of the object. Only applicable for objects of type Number.
Public propertyTime
Returns the time dimension of the object. Only applicable for objects of type Number.
Public propertyType
Returns the objects data type
Top
Methods
  NameDescription
Public methodToBool
Returns the objects value converted to a boolean. Only applicable for objects of type Number.
Public methodToDouble
Returns the objects value converted to a double. Only applicable for CalcValue objects of type Number.
Public methodToInt
Returns the objects value converted to an integer. Only applicable for CalcValue objects of type Number.
Public methodToString
Returns the objects value represented as a string.
Top
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next