ITeddsProject Interface

Interface for a project

Namespace:  Tekla.Structural.InteropAssemblies.Tedds
Assembly:  Tedds.TeddsIA (in Tedds.TeddsIA.dll) Version: 25.0.0.0
Syntax
public interface ITeddsProject

The ITeddsProject type exposes the following members.

Properties
  NameDescription
Public propertyBimProject
Linked BIM project
Public propertyFullName
Full path of project file including file name
Public propertyIsOpen
Is a project currently open
Public propertyName
Project name
Public propertyPath
Project file path (excludes file name)
Public propertyRootFolder
Root folder in the project tree
Public propertySaved
Saved status of project file
Top
Methods
  NameDescription
Public methodCalculate
Calculate all documents in the project
Public methodClose
Close the active project
Public methodNew
Create a new project
Public methodOpen
Open an existing project
Public methodSave
Save the active project file
Public methodSaveAs
Save the active project file to a new location
Public methodSaveAsPdf
Save all the documents in the project in PDF format
Public methodSendToWord
Export the project to Microsoft Word or Tedds for Word
Public methodSetBimProject
Link the Tedds project to a BIM project
Top
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next