IApplication Interface

Interface for the Main application

Namespace:  Tekla.Structural.InteropAssemblies.Tedds
Assembly:  Tedds.TeddsIA (in Tedds.TeddsIA.dll) Version: 25.0.0.0
Syntax
public interface IApplication

The IApplication type exposes the following members.

Properties
  NameDescription
Public propertyActiveDocument
Returns active document
Public propertyBuild
Returns the version build number of the Tedds software
Public propertyDocuments
Returns A Documents collection which represents all the open documents
Public propertyHeight
Height of the applications main window
Public propertyLeft
Position of the left edge of the applications main window
Public propertyProject
Returns the active project
Public propertyTop
Position of the top edge of the applications main window
Public propertyVersion
Returns the version number of the Tedds software
Public propertyVersionLibraryMajor
Returns the major version number of the Tedds Engineering Library
Public propertyVersionLibraryMinor
Returns the minor version number of the Tedds Engineering Library
Public propertyVersionMajor
Returns the major version number of the Tedds software
Public propertyVersionMinor
Returns the minor version number of the Tedds software
Public propertyVisible
Visibility status of the applications user interface
Public propertyWidth
Width of the applications main window
Public propertyWindowHandle
Returns the window handle of the applications main window
Public propertyWindowState
View state of the applications main window
Top
Methods
  NameDescription
Public methodActivate
Activates the user interface of the application
Public methodMove
Move the applications main window
Public methodQuit
Exit the application
Public methodResize
Size the applications main window
Top
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next