Tekla Structures 21.0 Open API Release Notes

Updated: 13 May 2019

This document explains new features, fixes and improvements in Tekla Open API 21.0. For more examples and information, see Tekla Open API Reference Manual for version 21.0. 

Tekla.Structures 21.0.0.0 Assembly

Faster start up and model loading

  • Tekla Structures start up and model loading is now faster than before. The loading and reloading of the plug-in with the Forms dialog box is now postponed until the plug-in is executed or the dialog box opened.
    The new functionality requires that StructuresData containing the dialog attributes is now located in the plug-in dll. Otherwise, an exception is thrown and the plug-in is not registered at all. 

Tekla.Structures.Model 21.0.0.0 Assembly

Construction points

  • Tekla Structures Open API now supports construction points

New solid creation type

  • Solid.SolidCreationTypeEnum.NORMAL_WITHOUT_WELDPREPS has been added to the part.GetSolid() method.

ModelHistory class adapted to work with Tekla Model Sharing

  • The following methods have been added:
    • GetNotSharedObjects() - returns a list of objects created or modified since the last Sharing WriteOut or multi-user save.
    • TakeModifications() - returns the modifications since the previous call and resets the modification stamp.
    • GetModifications() - returns the modifications since the previous call of TakeModifications() without resetting the modification stamp. 
  • The following methods are obsolete: 
    • GetModifiedObjects(), GetModifiedObjectsWithType(), GetDeletedObjects(), GetDeletedObjectsWithType(), GetCurrentModificationStamp()

Tekla.Structures.Drawings 21.0.0.0 Assembly

GetDrawing and GetOriginalDrawing methods

  • The GetDrawing method has been added to DrawingObject, which means that all objects now know to which drawing they belong.
  • The GetOriginalDrawing method has been added to the ViewBase class, which means views now know if they are linked to another drawing or not.
    The method returns the linked drawing if it exists, otherwise null is returned.
  • The views originating from the following commands now return valid drawings through the Drawing API: 
    • Add views from Other Drawing > Link or Link with Layout.
      Note that Copy or Copy with Layout do NOT return any linked drawing information, they are treated as original views of the drawing. 
    • The Move to drawing command is available when right-clicking a view frame. 

LoadAttributes

  • Previously, calling LoadAttributes for the layout of a drawing did not work. This has now been fixed and the layouts can be loaded just as if done from the Tekla Structures user interface. 

Bold and italic font in drawings

  • Setting the font of a text to bold or italic did not give the correct presentation in the drawing. This has now been fixed. 

Hidden drawing objects

  • The following drawing objects can now be hidden: 
    • ModelObject (all objects inherited from the ModelObject class) 
    • WeldMark (the drawing weld mark) 
    • Text
    • Symbol
    • MarkBase (all marks)
    • GraphicObject (all graphical objects) 
    • DimensionBase (all single dimensions)
    • DimensionSetBase (all dimension sets) 
  • The classes implement the interface IHideable, if you encounter a class supporting this interface you can access the Hideable member.
    The Hideable member has the following information: 
    • bool IsHidden, which gives the information if the object is hidden or visible.
    • HideFromDrawingView() function hides the object in the current view it exists in.
    • HideFromDrawing() function hides the object in all the views it exists in. 
    • ShowInDrawingView() function shows the object in the current view it exists in. 
    • ShowInDrawing() function shows the object in all the views it exists in.

View labels

  • In some situations, view labels could get an extra Name element when modified with the Mini Toolbar. This no longer happens. 

 

Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.