Tekla Structures 2023 Open API Release Notes

Updated: 16 Feb 2024

Tekla Open API 2021 release notes

TEKLA.STRUCTURES.DIALOG 2023.0.0.0 ASSEMBLY

  • Previously, shape selection from the shape catalog failed from the Wpf plugin dialogs. This problem has now been fixed.
    TTSD-50109
  • Pressing Apply no longer causes an exception and a crash when a Wpf dialog is opened with the Properties command from the Applications&Components catalog.
    TTSD-54793

TEKLA.STRUCTURES.PLUGINS.DIRECTMANIPULATION 2023.0.0.0 ASSEMBLY

  • The SelectedChanged event has been added to the HandleBase class for handling selection changing cases.
    TTSD-49771
  • The new RefreshManipulationContexts method has been added to the direct manipulation API for components and custom parts to clear and create new manipulators during runtime.
    TTSD-49772
  • The failed initialization of the Custom Part creation feature has now been fixed.
    TTSD-51887

TEKLA.STRUCTURES.DRAWINGS 2023.0.0.0. ASSEMBLY

  • The GetOriginalDrawing method was not getting the drawing type property correctly, which caused assemblies or containers to be left undrawn. This problem has now been fixed.
    TTSD-49877

TEKLA.STRUCTURES.MODEL 2023.0.0.0. ASSEMBLY

  • The new FetchModelObjects(List<Identifier> identifiers, bool Selectinstances) method has been added to the Model class for fetching model objects based on an identifier list. If the model object is invalid or selection fails, the model object is not included in the returned model object list.
    TTSD-49378
  • The new SetUserProperties() method has been added to the ModelObject class for setting multiple UDA values at the same time for a model object.
    TTSD-49463
  • The RebarPropertyModifier object now has a new FatherPart property, which can be used to set the parent part for all rebar set bars that intersect the modifier.
    TTSD-50333
  • Source data (COMMIT, UNDO_REDO, ROLLBACK) information is now added to the ChangeData class that is used in the OnModelObjectChanged() event.
    TTSD-50383
  • Support has been added for the new rebar_database.inp tolerance settings ExtraPointShortening, CurveTolerance, and MaxRadiusRequiringBending.
    TTSD-50581
  • The performance of the GetObjectsByBoundingBox() method when reference model objects are visible in the model view has been significantly improved.
    TTSD-51162
  • The new ConvertPartToItem() method was added to the Operation class.
    TTSD-54247
  • The new ViewCameraChanged event for the changed camera position has been added.
    TTSD-54308
  • The new “enum simplified” parameter has been added to the Reinforcement.GetRebarComplexGeometries function. This parameter defines whether the simplified (rationalized or fabrication) Rebar Shape Recognition (RSR) geometry is returned. The rationalized geometry includes segmented arcs converted to true arcs by RSR, and the fabrication geometry includes arcs recognized as straight by RSR.
    TTSD-54501,  TTSD-55777
  • DGN v8 can now be exported from the Operation class using the CreateDGNv8Export() method.
    TTSD-55624
  • It is now possible to change the orthogonal view to perspective using Tekla Structures Open API. The View.ViewProjection Property in namespace Tekla.Structures.Model.UI has been modified to also allow setting the value.
    TTSD-55835

TEKLA.STRUCTURES.MODULEMANAGER.CONFIGURATION 2023.0.0.0. ASSEMBLY

  • Previously, Tekla.Structures.ModuleManager.Configuration returned CONFIGURATION_VIEWER when you opened a model with the Project Viewer role for Tekla Model Sharing. Now Tekla.Structures.ModuleManager.Configuration returns ProgramConfigurationEnum.CONFIGURATION_CARBON, which enables the expected extensions.
    TTSD-51708

TEKLA.STRUCTURES.PLUGINS 2023.0.0.0 ASSEMBLY

  • The new PluginPropertyPaneFeatureBase base class and the new Tekla.Structures.Plugins.PropertyPane.dll file for defining the user interface as a property pane for a plugin have been added. You can now define property groups (tabs in the property pane) and the properties that belong to each property group. Properties are divided into single, dual, catalog, and dropdown properties.

    If properties in the property pane are defined for a connection or a custom part, the type must be set in the InitializeFeature method. For example:

    this.InitializeFeature("SpliceConnection", "SpliceConnection", "no_help_implemented", 
    PropertyPaneType.Connection, string.Empty, false);


    If the type is not defined, default value is used (PluginBase).
    TTSD-53659

  • These new methods have been added for creating distance and angle value boxes on the toolbar:

    • CreateDistanceValueTextBox(double? value = 0.0);

    • CreateAngleValueTextBox(double? value = 0.0);

TTSD-53946

Other Open API changes

  • Tekla Structures Open API now supports several special bolt holes for bolt groups.
    TTSD-50726
  • Tekla Structures Open API now supports tapped holes.
    TTSD-51150
  • Getting selected objects with the drawing API is now slightly faster.
    TTSD-51271
  • Previously, it was possible to set the parent part for rebar even though it was in a rebar assembly, resulting in conflicting rebar parents. This problem has now been fixed.
    TTSD-51567
  • Previously, modifying a container view with API code caused the view label to disappear. This problem has now been fixed.
    TTSD-51974
  • Tekla Structures OpenAPI now supports x and y offsets for bolts in slotted holes.
    TTSD-52635
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.