Tekla Structures 2020 Open API Release Notes

Updated: 16 Feb 2024

Tekla Open API version 2020 release notes are here.

TEKLA.STRUCTURES.ANALYSIS 2020.0.0.0 ASSEMBLY

TTSD-28688
AnalysisLoadGroup now has the IsEmpty() method.
The IsSelfWeight() method has also been added.

TTSD-28691
Tekla.Structures.Analysis.UI.AnalysisObjectSelector.GetSelectedObjects has been added to the Analysis & Design API that provides the enumerator of the selected Analysis & Design objects in the user interface.

TTSD-28692
Tekla.Structures.Analysis.UI.AnalysisObjectSelector.SetSelectedObjects has been added to the Analysis & Design API. It enables selecting Analysis & Design objects in the user interface.

TTSD-30937
AnalysisSubSection points are now returned correctly.

TTSD-31511
AnalysisLoadGroup.GetTypeName() has been added to get the translated name of the load group type.

TTSD-30338
Previously, analysis object UI selection only worked for analysis part/node/node links. Now also AnalysisMember/AnalysisBar/AnalysisArea can be passed, and the corresponding analysis part is selected.

 

TEKLA.STRUCTURES.CATALOG 2020.0.0.0. ASSEMBLY

TTSD-27466
Rebar selection based on grade, size, usage, and code has been added to Open API.

TTSD-32085
Pour unit has been added to CatalogObjectTypeEnum in CatalogHandler.

TTSD-25190
It is now possible to Insert the RebarItem into the rebar database.

TTSD-25191
It is now possible to Delete the RebarItem from the rebar database.

TTSD-25192
It is now possible to Modify the RebarItem in the rebar database.

 

TEKLA.STRUCTURES.DIALOG 2020.0.0.0 ASSEMBLY

TTSD-32317
It is now possible to change the visible text with the ButtonText property in all Catalog UI controls used in the Forms dialog boxes.

 

TEKLA.STRUCTURES.DRAWINGS 2020.0.0.0. ASSEMBLY

TTSD-25773
There is now a new method called GetAdvancedOptionPaths, which allows you to provide an advanced option name, and which generates a list of valid paths specified in that option. The method handles any invalid path strings and has an optional callback mechanism that may be used to log error information. See the API documentation for further information.

TTSD-27894
The following methods could cause Tekla Structures to be in the drawing mode without a drawing being open, and you could not work in the model normally. This has now been fixed.

  • DrawingHandler.PrintDrawing(Drawing drawing, DPMPrinterAttributes printAttributes)
  • DrawingHandler.PrintDrawing(Drawing drawing, DPMPrinterAttributes printAttributes, string outputFile)
  • DrawingHandler.PrintDrawings(List<Drawing> drawings, DPMPrinterAttributes printAttributes)

TTSD-28918
Reference models now work better when given as a parameter to the View constructor.

TTSD-34313
Previously, there was an issue where applications were unregistered from drawing events when Layout editor was opened. This issue has now been resolved.

 

TEKLA.STRUCTURES.MODEL 2020.0.0.0. ASSEMBLY

TTSD-20583
Previously, there was an assertion when trying to use the solid of a circular rebar. Now there should not be any asserts anymore.

TTSD-26856
It is now possible to delete reference model versions through ReferenceModel Open API.

TTSD-28676
The ClipPlane class now supports the changing of the clip plane border visibility and clip plane scissor icon visibility for clip planes.

TTSD-29185
There is a new Open API available for solids to get the solid status, whether the solid is valid or not: solid.IsValid(). It returns true if the solid is valid, otherwise it returns false.

TTSD-29399
Tekla.Structures.Model.UI.Picker now has two new overrides for PickPoints() methods. Points can now be picked with reference to a point sent in the parameter list.

TTSD-32306
Previously, there was an issue in the ShapeItem.Modify, ShapeItem.Insert and ShapeItem.Select methods, which caused the ShapeItem.UpAxis property value to always remain as it was set before the method call, in other words, the method did not set it to a possibly different value depending on the value in the shape catalog. 
With the Insert or Modify operation, the Tekla Structures core always stores shapes in the y axis up direction. 
Previously, if the input had other values than y axis up direction, the return value was incorrect after the method call. Especially, calling Modify repeatedly caused the shape to be rotated 90 degrees on every call, which was not wanted.

TTSD-24485
Added support for rebar catalog headers to the Open API.

 

TEKLA.STRUCTURES.PLUGINS 2020.0.0.0 ASSEMBLY

TTSD-31135
SymbolVisibility can now be used in the plug-in code to define whether the plug-in symbol is visible in model views.
For example:
[PluginSymbolVisiblity(PluginBase.SymbolVisibility.DO_NOT_DRAW_SYMBOL)]

TTSD-31338
The component instance is now deleted from the database if the code returns false and nothing is created.

TTSD-32813
Tekla Open API MessagesFolder is now deprecated. Use the MessagesFolder that returns all configured messages paths.

 

Headless Tekla Structures

TTSD-31433

The headless TeklaStructuresService now handles the different license names case insensitively.

TTSD-31416

Headless Tekla Structures now works for pours.

 

 

 

Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.