Tekla Structures 2018 Open API Release Notes

Updated: 7 Feb 2024

This document explains new features, fixes and improvements in Tekla Open API 2018. For more examples and information see API Reference.

Tekla Open API 2018 Release Notes

Tekla.Structures.Model 2018.0.0.0 Assembly

  • Construction object category filter expressions are now available in Open API. TTSD-10104
  • Using plug-ins to create a detail on a bent plate that is created using the AddLeg method does not change the GUID of the bent plate anymore. Using operations will still change the GUID. TTSD-8924
  • Filter expressions created with Open API now support constant filter expressions with multiple values. TTSD-10585
  • The ModelObjectChanged and ModelObjectNumbered events are now sending objects in collections of 1000 objects instead of sending all objects in one big list. TTSD-7269
  • A new method FetchModelObjects(List<string> guids, bool SelectInstances) has been added to the Model class for fetching model objects based on GUIDs. The GUID string is in a format such as "3uHlhzkIL0ox3dN3_MDYi3". The GUID type can be native (from a Tekla Structures model) or external (from a reference model).
    Objects can be selected by setting SelectInstances to true (default) or fetched without selection (for faster performance). TTSD-6520 
  • The PointCloud class has been added to Open API for managing point clouds. TTSD-7294
  • Tekla Model Sharing now correctly resolves conflicts for dynamic strings. TTSD-7607
  • The SetUserProperty method is now faster when the value does not actually change. TTSD-7728
  • A model plug-in without user interface definition attributes can again be inserted via API. TTSD-9150
  • It is possible to change the bent plate main section through Open API. Currently only a polygon section can be the main section of a bent plate. TTSD-9249
  • It is now possible to return the default value for assembly name by setting the name to be the same as the primary part name in Assembly::Modify();. TT87562
  • The workplane symbol in the model view is not refreshed anymore in with CommitChanges(). This caused workplane symbol to be located in an incorrect position in the view when executing plug-ins. The workplane symbol can be redrawn with the RedrawWorkplane() method in the ViewHandler class. TT131522

Tekla.Structures.Drawings 2018.0.0.0 Assembly 

  •  MarkBase.Attributes.PlacingAttributes.PlacingDistance.Maxi malDistance has been added to Open API. The default value 0.0 means no restriction. Other values indicate the desired maximum length for the leader line. TTSD-7800
  • The Open API Drawing class now has Drawing.OutputDate, and XS_DISABLE_DRAWING_PLOT_DATE controls whether this date is set when printing or exporting the drawing. TTSD-9753
  •  It is now possible to select and modify weld object attributes, and to load weld object attribute files through Open API. TTSD-10244
  • The new Open API drawing object property Drawing.IsIssuedButModified returns true when a drawing has been issued but then modified since the last issue. Otherwise it returns false. TTSD-8186
  • It is now possible to set/get the visibility of weld seam attributes and common attributes of model weld marks through Open API. It is also possible to set/get their text color, height and font, and background mask. TTSD-8380
  • Previously, Open API for rebar marks with pullout pictures reported the wrong frame size. This has now been fixed. TTSD-7051
  • Drawing.IsLocked now sets or clears the Drawing is locked by username field, and this field is now made available through the new property Drawing.IsLockedBy. TTSD-7041
  • SetMessageExecutionStatus has been deprecated, and the message execution status is no longer adjustable. It now defaults to BY_COMMIT. TTSD-6908
  • Change of behavior: If a mark is changed via Open API, only the fields that are changed will be affected. This only affects alignment commands. After a mark has been aligned using an alignment command, the mark's content cannot be changed anymore from higher level (view properties, for example). Now the alignment commands do not affect the possibility to change mark content from the higher level. TTSD-4659
  • Straight dimensions can now be added. TTSD-4654
  • A new DrawingUpdated event with change type and drawing information has been added to the Events class. TTSD-2940 • You can now issue and unissue a drawing using the new DrawingHandler.IssueDrawing and DrawingHandler.UnissueDrawing methods. TTSD-1915

Tekla.Structures.Dialog 2018.0.0.0 Assembly 

  •  WPF dialog support has been added for plug-ins and applications. New classes ApplicationWindowBase and PluginWindowBase have been added for defining dialogs with WPF. WPF user controls for catalogs, saveload and dialog button rows have been added to Tekla.Structures.Dialog.UIControls. TT131253
  • Rebar catalog control now sorts rebars based on diameter, not by label. TT124136 

Tekla.Structures.Catalogs 2018.0.0.0 Assembly 

  • Fetching of different bolt lengths based on size and grade has been added to Open API with new a property Lengths. TT131009
  • Distance value comparison now uses 1.0e-4 tolerance for distances that use imperial units. TT131033 

Tekla.Structures.CustomPropertyPlugin 2018.0.0.0 Assembly 

  •  Custom properties now always follow the contentattributes.lst settings. TTSD-2026 

Tekla.Structures.Analysis 2018.0.0.0 Assembly

  • The AreaSupportEnum attribute of the AnalysisPartAreaAttributes is not in use anymore. Use the AreaSupportTypeEnum instead. TTSD-3595

Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.