Tekla Structures 2017 Open API Release Notes

Updated: 13 May 2019

This document explains new features, fixes and improvements in Tekla Open API 2017. For more examples and information, see Tekla Open API Reference Manual for version 2017. 

Tekla Open API release notes

Tekla.Structures.CustomPropertyPlugin 2017.0.0.0 Assembly

  • Earlier, custom properties were loaded from all folders and subfolders in \common\extensions. This caused performance issues and loading failures when custom properties were used. Now the custom properties are loaded only from the extension folder \common\extensions\custom\properties.
    This speeds up the loading process and solves loading problems caused by other software components in other extension folders. The new functionality for loading custom properties can be switched off in startup .ini files by defining the following advanced option:
    set XS_ENABLE_FAST_CUSTOM_PROPERTY_LOADING=FALSE
    When you do this, the loading of custom properties works as in previous versions.

Tekla.Structures.Catalog 2017.0.0.0 Assembly

  • Added new command line TSEP builder options to modify extension product version, and to append product version to the .tsep file name. See TSEP documentation in Tekla Open API startup package for full details.
  • ShapeItem class has been added to Tekla Open API for inserting new shapes to shape catalog. Shapes can be used for creating new B-rep parts to model.

Tekla.Structures.Model 2017.0.0.0 Assembly

  • ModelObjectChanged and ModelObjectNumbered events now return the correct type for objects, such as PolyBeam instead of Beam.
  • Rebar groups with only one bar were not coming through the Tekla Open API correctly. This has now been fixed.
  • New method has been added to TeklaStructuresInfo class:
    public static string GetCopyRightText ()
  • FacetedBrep class has been added to Tekla.Structures.Geometry3d:
    public FacetedBrep (Vector[] vertices, int[][] outerWires, IDictionary`2 innerWires, IList`1 edges)
  • New properties have been added to all model objects:
    Property: bool IsUpToDate { public get; }
    Property: Nullable`1 ModificationTime { public get; }
  • The following classes have been added to BentPlate objects:
    • BentPlate class has been added for modifying bent plate objects.
    • BentPlateGeometrySolver class has been added for modifying bent plate geometry.
    • ConnectiveGeometry class has been added for finding out connecting geometry points between connecting plates for bent plate.
    • CylidricalSurface class has been added for forming cylinder for bent plate.
    • GeometrySection and GeometrySectionEnumerator classes has been added for inquiring bent plate geometry.
    • PolygonNode class has been added for creating new nodes to BentPlate.
  • Close() method has been added to the ModelHandler class.
  • New Polymesh class has been added for creating new ShapeItem objects.
  • The following classes have been added for modifying new RebarSet objects:
    • RebarEndDetailModifier class has been added for modeling rebar end details.
    • RebarGuideLine class has been added for creating new guide lines
    • RebarLegFace class has been added for modifying rebar set geometry.
    • RebarProperties class has been added for modifying properties of rebar set.
    • RebarSetAddition class has been added for overriding default behaviour of rebar set.
    • RebarSpacing and RebarSpacingZone classes have been added for defining spacing for rebars in RebarSet.
    • RebarSplice and RebarSplitter classes has been added for splitting rebars in RebarSet.
  • New methods have been added to the ModelHistory class in the Tekla.Structures.Model.History namespace:
    public static ModificationInfo GetModifications ()
    public static ModificationInfo TakeModifications ()
    public static void UpdateModificationStampToLatest ()
  • New class ModelObjectInfo has been added to the Tekla.Structures.Model.History namespace to give more information about what has changed in the object..
  • New properties for visibility and representation have been added to the view class in the Tekla.Structures.Model.UI namespace.
    string CurrentRepresentation { public get; public set; }
    Property: ViewVisibilitySettings VisibilitySettings
  • New methods for modifying bent plates and pour units have been added to the Operations class in the Tekla.Structures.Model.Operations namespace.
    public static bool CalculatePourUnits ()
    public static bool RemoveFromPourUnit ()
    public static BentPlate CreateBentPlateByFaces ()
    public static BentPlate CreateBentPlateByFaces ()
    public static BentPlate CreateBentPlateByFaces ()
    public static BentPlate CreateBentPlateByFaces ()
    public static BentPlate CreateBentPlateByParts ()
    public static BentPlate CreateBentPlateByParts ()
    public static bool ExplodeBentPlate ()
  • For single user and multi-user models, ModelHistory.GetModifications () and ModelHistory.TakeModifications () did not return the objects which were created in the same session and deleted before saving. Now this is fixed. The objects which are created between the previous model save/open and taking a ModificationStamp, and deleted before the next save, are reported as deleted since that ModificationStamp.

Tekla.Structures.Datatypes 2017.0.0.0 Assembly

  • Tolerance check has been added to value comparison for Double and Distance types.

Tekla.Structures.Drawings 2017.0.0.0 Assembly

  • Tekla Open API drawings now support RebarSet generated drawing rebar groups (ReinforcementSetGroup).
  • TextFile object now inherits from EmbeddedObjectBase.
  • New properties have now been added to all drawing classes:
    bool IsReadyForIssue { public get; }
    string IsReadyForIssueBy { public get; }
    string SectionViewStartLabel { public get; }
  • DimensionValueFormats.SuperscriptEnding value has been added to DimensionSetbaseAttributes class.
  • DWGScalingOptions class has been renamed to EmbeddedObjectScalingOptions and is used in the Scaling property of the EmbeddedObjectAttributes class. 
  • New image class has been added to the namespace for modifying images in drawings.

Tekla.Structures.Analysis 2017.0.0.0

  • New method has been added to AnalysisPartClass:
    public bool MovePosition (AnalysisPosition position, Vector move)
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.