Tekla Structures 2016i Open API Release Notes

Updated: 13 May 2019

This document explains new features, fixes and improvements in Tekla Open API 2016i. For more examples and information, see Tekla Open API Reference Manual for version 2016i. 

Tekla.Structures.Catalog 2016.1.0.0 Assembly

  • Missing object types have been added for the UserPropertyItem enumerator:
    • Steel and concrete item
    • Chamfer
    • Surface object
    • Grid plane
  • In Tekla Open API, the ComponentCatalog control does not crash in applications anymore.
  • ComponentCatalog control now returns the component number for plugins.
  • Importing .lis profiles from a folder now works correctly.

Tekla.Structures.Dialog 2016.1.0.0 Assembly

  • The applications that are inherited from ApplicationFormBase can now be executed without having Tekla Structures open.

Tekla.Structures.Model 2016.1.0.0 Assembly

  • There is a new method,
    Tekla.Structures.Model.Operations.Operation.ShowOnlySelect ed(UnselectedMode), that has the same functionality as the Show only selected part user interface command. 
  • The ReferenceModelObject class now has a new method that gets a ReferenceModelObject with an external GUID. If the reference model does not contain an object with the specified GUID, the method returns null.
    The method signature is as follows:
    ReferenceModelObject Tekla.Structures.Model.ReferenceModel.GetReferenceModelObjectByExternalGuid(string externalGuid)
  • A new ModelObjectChanged event has been added to Open API. The event contains object information as well as the type of the change (insert, modify, delete, or Userproperty changed). The event is also sent when the undo/redo action is done in the user interface. 
  • There is a new event, ModelObjectNumbered, with object information in the Events class. The event is sent when the object is numbered. 
  • Previously, ReferenceModel.GetChildren() returned nothing for IFC imported from Trimble Connect. This has now been fixed. 

Tekla.Structures-drawings 2016.1.0.0 Assembly

  • There is now new functionality for rotating views:
    • RotateOnDrawingPlane
      This works in the same way as the Rotate view user interface command. 
    • RotateViewOnAxisX, RotateViewOnAxisY, RotateViewOnAxisZ
      These rotate the view in its internal coordinate system on the X, Y, and Z axis respectively.
  • The section view now has the filtering type and the main part from its parent. If a section view is created from the assembly front view, it then shows the parts of the assembly. 
  • It is now possible to add a coordinate system and extrema to a view (3D view) in an assembly drawing.
    bool Create3dView(Drawing drawing, CoordinateSystem viewPlane, CoordinateSystem displayPlane, AABB viewExtrema, Point viewInsertionPoint, ViewAttributes viewAttributes, out View view)
  • Setting the ExcludePartsAccordingToFilter field for StraightDimensionSets with more than one dimension did not work properly. This has now been fixed.
  • There is now Open API support for individual bulges for polygons and polylines.
  • New methods have been added to DatabaseObject to get a list of UDA values with a list of UDA names:
    • public bool GetStringUserProperties(List<string> names, ref Dictionary<string, string> values) 
    • public bool GetDoubleUserProperties(List<string> names, ref Dictionary<string, double> values) 
    • public bool GetIntegerUserProperties(List<string> names, ref Dictionary<string, int> values)
    There are also new methods to get all UDA values of a given type:
    • public bool GetStringUserProperties(out Dictionary<string, string> values) 
    • public bool GetDoubleUserProperties(out Dictionary<string, double> values) 
    • public bool GetIntegerUserProperties(out Dictionary<string, int> values) 

 

Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.