Tekla Structures 18.0 Open API Release Notes

Updated: 13 May 2019

This document explains new features, fixes and improvements in Tekla Open API 18.0. For more examples and information, see Tekla Open API Reference Manual for version 18.0.

Tekla.Structures 18.0.0.0 Assembly

Get and set clash check and component options

  • It is now possible to get and set clash check and component options using the TeklaStructuresSettings class.

Tekla.Structures.Plugins 18.0.0.0 Assembly

New property for connection code

  • A new Code property has been added to the ConnectionBase class. The property represents the connection code of the executable connection instance.

Tekla.Structures.Model 18.0.0.0 Assembly

Set label to identify modifications

  • A new SetLabel method has been added to the ModelObject class. The label can be used for identifying the object that has changed in plug-in modification.

Split reinforcements

  • Methods for splitting SingleRebar, CurvedRebarGroup and CircleRebarGroup have been added to the Operation class.

New property for connecting assemblies

  • A new Boolean ConnectAssemblies property has been added to the BoltGroup class. The property indicates whether to connect a part or an assembly as a secondary part (false) or as a sub-assembly (true).

New property for model sharing

  • A new Boolean SharedModel property has been added to the ModelInfo class to indicate whether the model is shared or not.

New from plane offset properties

  • Support for creating rebar groups and bent meshes that have different from plane values applied in the beginning and in the end of the group/mesh has been added. The new properties are called StartFromPlaneOffset and EndFromPlaneOffset. The old FromPlaneOffset property is still available. If the old property is used, the value is applied in both places as it was done before.

Tekla.Structures.Drawing 18.0.0 Assembly

Get related objects

  • Functionality for getting the related objects has been added for every drawing object. The GetRelatedObjects methods retrieve the related objects for the current object. For example, a mark is related to a model object, or vice versa. Please note that this functionality is not yet available for dimensions.

Mark improvements

  • It is now possible to use the Mark.Insert method. Marks inserted through the Open API are inserted as associative notes. Merged marks are not yet available. Upon the insertion of a mark, the leader line start point is restricted to the model object.
  • The Mark.MarkAttributes.LoadAttributes method has now been implemented.
  • Marks can now contain property element content types. The PropertyElement class now has a constructor for this purpose.
  • UserDefinedElements can now return their current value.

Fixes

  •  The view enumeration in drawings no longer finds the content of keyplan views.
  • The LoadAttributes method in the StraightDimensionSetAttributes class now works for dimension and dimension set tags. The old constructors in the StraightDimensionSetAttributes class have been marked as obsolete and the new constructors that take a ModelObject as a parameter should be used instead.
  • When the content of an associative note was edited through the Open API, change symbols always appeared. This has now been fixed.
  • The DrawingCoordinateConverter was working incorrectly in version 17.1 when given points which included Z values of points. This has now been fixed.

Tekla.Structures.Dialog 18.0.0.0 Assembly

Common progress bar control

  • A new TeklaProgressBar class has been added. The class represents the common progress bar control for the Open API.

Fixes

  • The name of the usage is now translated in the ReinforcementSelectionForm UI control.

Tekla.Structures.Catalogs 18.0.0.0 Assembly

User properties

  • It is now possible to enumerate/select/insert/update/delete user properties (user defined attributes as defined by the objects.inp file(s)). When inserting a user property, it will be a model level property (as if defined in objects.inp in the model folder). Only model level items can be updated or deleted.
  • User property assignments to object types can be queried and modified.
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.