Definitions

Updated: 13 May 2019

This guide includes definitions of useful some terms related to the Tekla Open API.

Application (.exe)

Application is a tool executed in a separated process. Applications can use WindowsForms, WPF, or just be console applications without UI. In Tekla Structures, start applications from the Applications & components catalog.

Macro (.cs)

Macros are recorded or manually created .cs files stored in the folder defined by the XS_MACRO_DIRECTORY advanced option. In Tekla Structures, start macros from the Applications & components Catalog.

Macros are C# source files (.cs) that are compiled at run-time. 

Macros can, for example, be used for creating drawings or reports. Macros are also sometimes used to run an application.

Plug-in (.dll)

The Tekla.Structures.Plugins assembly provides for example following classes for creating plug-ins:

Class               Description
PluginBase   An abstract base class for component tools.

PluginFormBase

 

 

 

 

 

 

 

A base class for plug-ins that use Windows Forms for dialog design. Class adds the following support:

  • .Net dialogs

  • Data connections

  • Tekla Structures data types and conversions automatically

  • Multiple language support

  • Storing of default values

ConnectionBase

  Base class for defining Connections, Details and Seams. These types are more specialized and restricted by the input values than the ones derived from PluginBase.

CustomPartBase

  Base class for defining custom parts.

DrawingPluginBase

  An abstract base class for drawings plug-ins. Contains the user-interface and the dialog using the PluginFormBase.
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.