API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

ShapeCatalog Constructor (String)

Initializes a new instance of the ShapeCatalog class and will select the Shape (if available) in the tree.

Namespace:  Tekla.Structures.Dialog.UIControls
Assembly:  Tekla.Structures.Dialog (in Tekla.Structures.Dialog.dll) Version: 2023.0.1
Syntax
public ShapeCatalog(
	string shape
)

Parameters

shape
Type: SystemString
The Shape to be selected in the dialog.
See Also