![]() | ShapeCatalog Class |
The ShapeCatalog class represents a group of controls to select Shapes
using the Shape catalog.

SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsUserControl
Tekla.Structures.Dialog.UIControlsShapeCatalog
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsUserControl
Tekla.Structures.Dialog.UIControlsShapeCatalog
Namespace: Tekla.Structures.Dialog.UIControls
Assembly: Tekla.Structures.Dialog (in Tekla.Structures.Dialog.dll) Version: 2023.0.1

The ShapeCatalog type exposes the following members.

Name | Description | |
---|---|---|
![]() | ShapeCatalog |
Initializes a new instance of the ShapeCatalog class.
|
![]() | ShapeCatalog(String) |
Initializes a new instance of the ShapeCatalog class and will select
the Shape (if available) in the tree.
|

Name | Description | |
---|---|---|
![]() | ButtonText |
Gets and sets the text of the button control.
|
![]() | SelectedShape |
Gets or sets the selected Shape in the control.
|

Name | Description | |
---|---|---|
![]() | OnValueChanged |
Event handler for passing generic catalog data back to dialog
|

Name | Description | |
---|---|---|
![]() | SelectClicked |
The SelectClicked event is raised when the Select button is clicked.
|
![]() | SelectionDone |
The SelectionDone event is raised when the selection has been done.
|