![]() | SaveLoad Class |
The SaveLoad class represents a save-load-save as group of controls including the functionality.

SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsUserControl
Tekla.Structures.Dialog.UIControlsSaveLoad
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsUserControl
Tekla.Structures.Dialog.UIControlsSaveLoad
Namespace: Tekla.Structures.Dialog.UIControls
Assembly: Tekla.Structures.Dialog (in Tekla.Structures.Dialog.dll) Version: 2023.0.1

The SaveLoad type exposes the following members.

Name | Description | |
---|---|---|
![]() | SaveLoad |
Initializes a new instance of the SaveLoad class with the default language and file extensions.
|

Name | Description | |
---|---|---|
![]() | HelpFileType |
Gets or sets the help file type.
|
![]() ![]() | HelpKeyword |
Gets or sets the HelpKeyword that the help file should be opened for.
If you do not provide a HelpKeyword and HelpUrl is not set, the default
start page for Tekla Structures Help viewer is displayed.
|
![]() | HelpUrl |
Gets or sets the HelpUrl where the help file is located.
If you do not provide a HelpUrl, the Tekla Structures help viewer will be displayed with given HelpKeyword.
|
![]() | SaveAsText |
Gets or sets the text in the SaveAs text box.
|
![]() | SaveLoadText |
Gets the currently selected file name in the Save/Load combo box.
|
![]() | UserDefinedHelpFilePath |
Gets or sets the file path where the UserDefined help file is located.
If you do not provide a UserDefinedHelpFilePath, the general Help file, help.chm, will be displayed.
|

Name | Description | |
---|---|---|
![]() | AttributesLoadClicked |
The AttributesLoadClicked event is triggered just after the load button has been clicked.
|
![]() | AttributesLoaded |
The AttributesLoaded event is triggered just after attributes have been loaded into the dialog.
|
![]() | AttributesSaveAsClicked |
The AttributesSaveAsClicked event is triggered just after the save as button has been clicked.
|
![]() | AttributesSaveClicked |
The AttributesSaveClicked event is triggered just after the save button has been clicked.
|
![]() | AttributesSaved |
The AttributesSaved event is triggered just after attributes are saved to a file.
|
![]() | AttributesSavedAs |
The AttributesSavedAs event is triggered just after attributes are "saved as" to a file.
|
![]() | HelpOpenClicked |
The HelpOpenClicked event is triggered just after the help button has been clicked.
|
![]() | HelpOpened |
The HelpOpened event is triggered just after the help file is opened.
|