API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

ReinforcementSelectionForm Constructor (ListRebarItem)

Creates a new instance of the ReinforcementSelectionForm.

Namespace:  Tekla.Structures.Dialog.UIControls
Assembly:  Tekla.Structures.Dialog (in Tekla.Structures.Dialog.dll) Version: 2023.0.1
Syntax
public ReinforcementSelectionForm(
	List<RebarItem> RebarList
)

Parameters

RebarList
Type: System.Collections.GenericListRebarItem
A list with the rebars that will be added to the tree.
See Also