![]() | ReinforcementSelectionForm Class |
The ReinforcementSelectionForm class represents a dialog to select rebars
using the rebar catalogs.

SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsForm
Tekla.Structures.Dialog.UIControlsReinforcementSelectionForm
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsForm
Tekla.Structures.Dialog.UIControlsReinforcementSelectionForm
Namespace: Tekla.Structures.Dialog.UIControls
Assembly: Tekla.Structures.Dialog (in Tekla.Structures.Dialog.dll) Version: 2023.0.1

The ReinforcementSelectionForm type exposes the following members.

Name | Description | |
---|---|---|
![]() | ReinforcementSelectionForm(ListRebarItem) |
Creates a new instance of the ReinforcementSelectionForm.
|
![]() | ReinforcementSelectionForm(ListRebarItem, String, String, Double) |
Creates a new instance of the ReinforcementSelectionForm and will select in the tree
the rebar that contains the given parameters (if possible).
|
![]() | ReinforcementSelectionForm(ListRebarItem, String, String, Double, String) |
Creates a new instance of the ReinforcementSelectionForm and will select in the tree
the rebar that contains the given parameters (if possible).
|

Name | Description | |
---|---|---|
![]() | Culture |
Gets the culture.
|
![]() | SelectedBendingRadius |
Gets the selected rebar bending radius.
|
![]() | SelectedGrade |
Gets the selected rebar grade.
|
![]() | SelectedSize |
Gets the selected rebar size.
|
![]() | SelectedUsage |
Gets the selected usage.
|