![]() | ReinforcementCatalog Class |
The ReinforcementCatalog class represents a group of controls to select rebars
using the rebar catalogs.

SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsUserControl
Tekla.Structures.Dialog.UIControlsReinforcementCatalog
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsUserControl
Tekla.Structures.Dialog.UIControlsReinforcementCatalog
Namespace: Tekla.Structures.Dialog.UIControls
Assembly: Tekla.Structures.Dialog (in Tekla.Structures.Dialog.dll) Version: 2023.0.1

The ReinforcementCatalog type exposes the following members.

Name | Description | |
---|---|---|
![]() | ReinforcementCatalog |
Initiates a new instance of the control.
|
![]() | ReinforcementCatalog(String, String, Double) |
Creates a new instance of the ReinforcementCatalog and will select in the tree
the rebar that contains the given parameters (if possible).
|

Name | Description | |
---|---|---|
![]() | ButtonText |
Gets and sets the text of the button control.
|
![]() | SelectedRebarBendingRadius |
Gets the selected rebar bending radius in the control.
|
![]() | SelectedRebarGrade |
Gets the selected rebar grade in the control.
|
![]() | SelectedRebarSize |
Gets the selected rebar size in the control.
|

Name | Description | |
---|---|---|
![]() | OnValueChanged |
Event handler for passing generic catalog data back to dialog
|

Name | Description | |
---|---|---|
![]() | SelectClicked |
The SelectClicked event is raised when the Select button is clicked.
|
![]() | SelectionDone |
The SelectionDone event is raised when the selection has been done.
|