API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

ProfileSelectionForm Constructor (ListLibraryProfileItem, ListParametricProfileItem)

Creates a new instance of the ProfileSelectionForm.

Namespace:  Tekla.Structures.Dialog.UIControls
Assembly:  Tekla.Structures.Dialog (in Tekla.Structures.Dialog.dll) Version: 2023.0.1
Syntax
public ProfileSelectionForm(
	List<LibraryProfileItem> LibraryProfiles,
	List<ParametricProfileItem> ParametricProfiles
)

Parameters

LibraryProfiles
Type: System.Collections.GenericListLibraryProfileItem
The library profiles to be added to the dialog.
ParametricProfiles
Type: System.Collections.GenericListParametricProfileItem
The parametric profiles to be added to the dialog.
See Also