API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

OkApplyModifyGetOnOffCancel Class

The OkApplyModifyGetOnOffCancel class represents a control including the Ok-Apply-Modify-Get-On/Off-Cancel button group.
Inheritance Hierarchy

Namespace:  Tekla.Structures.Dialog.UIControls
Assembly:  Tekla.Structures.Dialog (in Tekla.Structures.Dialog.dll) Version: 2023.0.1
Syntax
public class OkApplyModifyGetOnOffCancel : UserControl

The OkApplyModifyGetOnOffCancel type exposes the following members.

Constructors
  NameDescription
Public methodOkApplyModifyGetOnOffCancel
Initializes a new instance of the OkApplyModifyGetOnOffCancel class.
Top
Events
  NameDescription
Public eventApplyClicked
The ApplyClicked event is raised when the Apply button is clicked.
Public eventCancelClicked
The CancelClicked event is raised when the Cancel button is clicked.
Public eventGetClicked
The GetClicked event is raised when the Get button is clicked.
Public eventModifyClicked
The ModifyClicked event is raised when the Modify button is clicked.
Public eventOkClicked
The OkClicked event is raised when the Ok button is clicked.
Public eventOnOffClicked
The OnOffClicked event is raised when the On-Off button is clicked.
Top
See Also