![]() | MeshCatalog Class |
The MeshCatalog class represents a group of controls to select meshes
using the mesh catalogs.

SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsUserControl
Tekla.Structures.Dialog.UIControlsMeshCatalog
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsUserControl
Tekla.Structures.Dialog.UIControlsMeshCatalog
Namespace: Tekla.Structures.Dialog.UIControls
Assembly: Tekla.Structures.Dialog (in Tekla.Structures.Dialog.dll) Version: 2023.0.1

The MeshCatalog type exposes the following members.

Name | Description | |
---|---|---|
![]() | MeshCatalog |
Initiates a new instance of the control.
|

Name | Description | |
---|---|---|
![]() | ButtonText |
Gets and sets the text of the button control.
|
![]() | SelectedMeshGrade |
The mesh grade in the control.
|
![]() | SelectedMeshName |
The mesh name in the control.
|

Name | Description | |
---|---|---|
![]() | SelectClicked |
The SelectClicked event is raised when the Select button is clicked.
|
![]() | SelectionDone |
The SelectionDone event is raised when the selection has been done.
|