API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

MaterialSelectionForm Constructor (ListMaterialItem)

Creates a new instance of the MaterialSelectionForm.

Namespace:  Tekla.Structures.Dialog.UIControls
Assembly:  Tekla.Structures.Dialog (in Tekla.Structures.Dialog.dll) Version: 2023.0.1
Syntax
public MaterialSelectionForm(
	List<MaterialItem> Materials
)

Parameters

Materials
Type: System.Collections.GenericListMaterialItem
The materials to be added to the dialog.
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.