![]() | MaterialCatalog Class |
The MaterialCatalog class represents a group of controls to select materials
using the material catalog.

SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsUserControl
Tekla.Structures.Dialog.UIControlsMaterialCatalog
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsUserControl
Tekla.Structures.Dialog.UIControlsMaterialCatalog
Namespace: Tekla.Structures.Dialog.UIControls
Assembly: Tekla.Structures.Dialog (in Tekla.Structures.Dialog.dll) Version: 2023.0.1

The MaterialCatalog type exposes the following members.

Name | Description | |
---|---|---|
![]() | MaterialCatalog |
Initiates a new instance of the control.
|
![]() | MaterialCatalog(String) |
Creates a new instance of the MaterialCatalog and will select
the material (if available) in the tree.
|

Name | Description | |
---|---|---|
![]() | ButtonText |
Gets and sets the text of the button control.
|
![]() | SelectedMaterial |
Gets the selected material in the control.
|

Name | Description | |
---|---|---|
![]() | SelectClicked |
The SelectClicked event is raised when the Select button is clicked.
|
![]() | SelectionDone |
The SelectionDone event is raised when the selection has been done.
|