API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

LoadingForm Class

The LoadingForm class creates a dialog that is shown while something is being loaded by the main window and that needs the process to finish.
Inheritance Hierarchy

Namespace:  Tekla.Structures.Dialog.UIControls
Assembly:  Tekla.Structures.Dialog (in Tekla.Structures.Dialog.dll) Version: 2023.0.1
Syntax
public class LoadingForm : Form

The LoadingForm type exposes the following members.

Constructors
  NameDescription
Public methodLoadingForm
Creates a new instance of the form.
Top
Properties
  NameDescription
Public propertyAllowClosing
Allows the closing of the dialog. By default disabled.
Top
See Also