API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

ImageList Class

The ImageList class contains a list of ImageItems.
Inheritance Hierarchy
SystemObject
  System.Collections.GenericListImageItem
    Tekla.Structures.Dialog.UIControlsImageList

Namespace:  Tekla.Structures.Dialog.UIControls
Assembly:  Tekla.Structures.Dialog (in Tekla.Structures.Dialog.dll) Version: 2023.0.1
Syntax
[SerializableAttribute]
public class ImageList : List<ImageItem>

The ImageList type exposes the following members.

Constructors
  NameDescription
Public methodImageList
Initializes a new instance of the ImageList class
Top
See Also