![]() | ImageComboBox Class |
Note: This API is now obsolete.
The ImageComboBox class represents a combo box control that can contain images.

SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsUserControl
Tekla.Structures.Dialog.UIControlsImageComboBox
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsUserControl
Tekla.Structures.Dialog.UIControlsImageComboBox
Namespace: Tekla.Structures.Dialog.UIControls
Assembly: Tekla.Structures.Dialog (in Tekla.Structures.Dialog.dll) Version: 2023.0.1

The ImageComboBox type exposes the following members.

Name | Description | |
---|---|---|
![]() | ImageComboBox |
Initializes a new instance of the ImageComboBox class.
|

Name | Description | |
---|---|---|
![]() | DefaultValue |
Gets or sets the default value in the image combo box.
|
![]() | OptionList |
Gets or sets the elements of the option list, the images that are in the image combo box.
|
![]() | SelectedIndex |
Gets or sets the selected index of the image in the image combo box.
|
![]() | SelectedItem |
Gets or sets the selected image in the image combo box.
|

Name | Description | |
---|---|---|
![]() | ImageCBSelectedIndexChanged |
The ImageCBSelectedIndexChanged event is triggered just after the selected index has been changed in the image combo box.
|