API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

EnvironmentFilesIsValidDirectory Method

Checks if a directory is valid.

Namespace:  Tekla.Structures.Dialog.UIControls
Assembly:  Tekla.Structures.Dialog (in Tekla.Structures.Dialog.dll) Version: 2023.0.1
Syntax
public static bool IsValidDirectory(
	string directory
)

Parameters

directory
Type: SystemString
The directory to be checked.

Return Value

Type: Boolean
True if the directory is valid.
See Also