API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

EnvironmentFilesGetMultiDirectoryFileList Method (ListString, String)

Gets a list of files with the given extension from the given search directories and from XS_FIRM, XS_PROJECT subdirectories.

Namespace:  Tekla.Structures.Dialog.UIControls
Assembly:  Tekla.Structures.Dialog (in Tekla.Structures.Dialog.dll) Version: 2023.0.1
Syntax
public static List<string> GetMultiDirectoryFileList(
	List<string> searchDirectories,
	string fileExtension
)

Parameters

searchDirectories
Type: System.Collections.GenericListString
The search directories to be used.
fileExtension
Type: SystemString
The file extension to be used.

Return Value

Type: ListString
A list of found file names without the file extension.
See Also