API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

EnvironmentFilesGetMultiDirectoryFileList Method (String)

Gets a list of files with the given extension from the default search directories.

Namespace:  Tekla.Structures.Dialog.UIControls
Assembly:  Tekla.Structures.Dialog (in Tekla.Structures.Dialog.dll) Version: 2023.0.1
Syntax
public static List<string> GetMultiDirectoryFileList(
	string fileExtension
)

Parameters

fileExtension
Type: SystemString
The file extension to be used.

Return Value

Type: ListString
A list of files with the given extension.
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.