API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

EnvironmentFilesGetAttributeFile Method (ListString, String)

Note: This API is now obsolete.

Gets a file info representing the first match in the search directories.

Namespace:  Tekla.Structures.Dialog.UIControls
Assembly:  Tekla.Structures.Dialog (in Tekla.Structures.Dialog.dll) Version: 2023.0.1
Syntax
[ObsoleteAttribute("Deprecated. Please use GetAttributeFile(string fileName) instead.", 
	false)]
public static FileInfo GetAttributeFile(
	List<string> searchDirectories,
	string fileName
)

Parameters

searchDirectories
Type: System.Collections.GenericListString
The list of directories to be used for searching for the file.
fileName
Type: SystemString
The name of the file including the file extension.

Return Value

Type: FileInfo
A file info for the first match in the directory list. Null if no match was found.
See Also