API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

EnvironmentFiles Class

The EnvironmentFiles class is for the paths where the attributes file will be searched for.
Inheritance Hierarchy
SystemObject
  Tekla.Structures.Dialog.UIControlsEnvironmentFiles

Namespace:  Tekla.Structures.Dialog.UIControls
Assembly:  Tekla.Structures.Dialog (in Tekla.Structures.Dialog.dll) Version: 2023.0.1
Syntax
public class EnvironmentFiles

The EnvironmentFiles type exposes the following members.

Constructors
  NameDescription
Public methodEnvironmentFiles
Initializes a new instance of the EnvironmentFiles class
Top
Properties
  NameDescription
Public propertyStatic memberPropertyFileDirectories
The directories where to look for property files.
Top
Methods
  NameDescription
Public methodStatic memberGetAttributeFile(String)
Gets a file info representing the first match in the standard property file directories.
Public methodStatic memberGetAttributeFile(ListString, String) Obsolete.
Gets a file info representing the first match in the search directories.
Public methodStatic memberGetAttributeFiles
Gets attribute files with specified suffix from model, XS_FIRM and XS_PROJECT directories and subdirectories.
Public methodStatic memberGetMultiDirectoryFileList(String)
Gets a list of files with the given extension from the default search directories.
Public methodStatic memberGetMultiDirectoryFileList(ListString, String)
Gets a list of files with the given extension from the given search directories and from XS_FIRM, XS_PROJECT subdirectories.
Public methodStatic memberGetStandardPropertyFileDirectories
Gets the paths where to look for the property files.
Public methodStatic memberIsValidDirectory
Checks if a directory is valid.
Top
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.