API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

CreateApplyCancel Class

The CreateApplyCancel class represents a control including the Create-Apply-Cancel button group.
Inheritance Hierarchy

Namespace:  Tekla.Structures.Dialog.UIControls
Assembly:  Tekla.Structures.Dialog (in Tekla.Structures.Dialog.dll) Version: 2023.0.1
Syntax
public sealed class CreateApplyCancel : UserControl

The CreateApplyCancel type exposes the following members.

Constructors
  NameDescription
Public methodCreateApplyCancel
Initializes CreateApplyCancel user control.
Top
Events
  NameDescription
Public eventApplyClicked
The ApplyClicked event is raised when the Apply button is clicked.
Public eventCancelClicked
The CancelClicked event is raised when the Cancel button is clicked.
Public eventCreateClicked
The CreateClicked event is raised when the Create button is clicked.
Top
See Also