API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

BoltCatalogStandard Class

The BoltCatalogStandard class represents a control to select the bolt standard using the bolt catalog.

Bolt catalog controls always need to be in pairs, meaning in every dialog there has to be a BoltCatalogStandard and a BoltCatalogSize control.

The property BoltCatalogStandard.LinkedBoltCatalogSize sets to which BoltCatalogSize the control is linked.

Inheritance Hierarchy

Namespace:  Tekla.Structures.Dialog.UIControls
Assembly:  Tekla.Structures.Dialog (in Tekla.Structures.Dialog.dll) Version: 2023.0.1
Syntax
public class BoltCatalogStandard : ComboBox

The BoltCatalogStandard type exposes the following members.

Constructors
  NameDescription
Public methodBoltCatalogStandard
Initiates a new instance of the control.
Top
Properties
  NameDescription
Public propertyLinkedBoltCatalogSize
The BoltCatalogSize control linked to the BoltCatalogStandard control. Bolt catalog controls always need to be in pairs, meaning in every dialog there has to be a BoltCatalogStandard and a BoltCatalogSize control.
Top
See Also