API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

TeklaProgressBar Class

The TeklaProgressBar class represents the common progress bar control for the Open API.
Inheritance Hierarchy

Namespace:  Tekla.Structures.Dialog
Assembly:  Tekla.Structures.Dialog (in Tekla.Structures.Dialog.dll) Version: 2023.0.1
Syntax
public class TeklaProgressBar : Form

The TeklaProgressBar type exposes the following members.

Constructors
  NameDescription
Public methodTeklaProgressBar
Initializes the common progress bar control.
Top
Properties
  NameDescription
Public propertyText
Gets or sets the current message text of the progress bar.
Public propertyValue
Gets or sets the current position of the progress bar.
Top
Events
  NameDescription
Public eventCancelClicked
The CancelClicked event is raised when the cancel button is clicked.
Top
See Also