API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

StructuresInstallation Class

Utility functions.
Inheritance Hierarchy
SystemObject
  Tekla.Structures.DialogStructuresInstallation

Namespace:  Tekla.Structures.Dialog
Assembly:  Tekla.Structures.Dialog (in Tekla.Structures.Dialog.dll) Version: 2023.0.1
Syntax
public static class StructuresInstallation

The StructuresInstallation type exposes the following members.

Properties
  NameDescription
Public propertyStatic memberBinFolder
Gets Path to Tekla Structures binary (bin) directory.
Public propertyStatic memberEnvBaseFolder
Gets Path to Tekla Structures XSDATADIR directory. XSDATADIR is defined in the teklastructures.ini file. It points to a location, where the installation installs the environment files and folders. Example: C:\ProgramData\Trimble\Tekla Structures\Version
Public propertyStatic memberInstallFolder Obsolete.
Gets path to Tekla Structures installation directory.
Public propertyStatic memberMessageFolder Obsolete.
Gets path to Tekla Structures messages directory.
Public propertyStatic memberMessagesFolder
Gets a list Paths to Tekla Structures messages directories.
Top
Methods
  NameDescription
Public methodStatic memberGetLocalizationFile(String)
Retrieves localization file from configured environment
Public methodStatic memberGetLocalizationFile(String, String)
Retrieves localization file from configured environment
Top
See Also