API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

StructuresExtenderSetAttributeName Method

Associates AttributeName text with the specified control.

Namespace:  Tekla.Structures.Dialog
Assembly:  Tekla.Structures.Dialog (in Tekla.Structures.Dialog.dll) Version: 2023.0.1
Syntax
public void SetAttributeName(
	Control control,
	string value
)

Parameters

control
Type: System.Windows.FormsControl
The control to associate the AttributeName text with.
value
Type: SystemString
The AttributeName text to associate with the control.
See Also