API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

StructuresExtenderGetBindPropertyName Method

Retrieves the BindPropertyName text associated with the specified control.

Namespace:  Tekla.Structures.Dialog
Assembly:  Tekla.Structures.Dialog (in Tekla.Structures.Dialog.dll) Version: 2023.0.1
Syntax
public string GetBindPropertyName(
	Control control
)

Parameters

control
Type: System.Windows.FormsControl
The control for which to retrieve the BindPropertyName text.

Return Value

Type: String
A string containing the BindPropertyName text for the specified control, or null if no text is associated with the specified control.
See Also