API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

StructuresExtenderGetAttributeName Method

Retrieves the AttributeName text associated with the specified control.

Namespace:  Tekla.Structures.Dialog
Assembly:  Tekla.Structures.Dialog (in Tekla.Structures.Dialog.dll) Version: 2023.0.1
Syntax
public string GetAttributeName(
	Control control
)

Parameters

control
Type: System.Windows.FormsControl
The control for which to retrieve the AttributeName text.

Return Value

Type: String
A string containing the AttributeName text for the specified control, or null if no text is associated with the specified control.
See Also