![]() | StructuresExtender Class |
The StructuresExtender class is for binding controls to datatypes. The bindings are
needed to transfer the dialog values to Tekla Structures and onwards to plug-ins.

SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
Tekla.Structures.DialogStructuresExtender
SystemMarshalByRefObject
System.ComponentModelComponent
Tekla.Structures.DialogStructuresExtender
Namespace: Tekla.Structures.Dialog
Assembly: Tekla.Structures.Dialog (in Tekla.Structures.Dialog.dll) Version: 2023.0.1

The StructuresExtender type exposes the following members.

Name | Description | |
---|---|---|
![]() | StructuresExtender | Initializes a new instance of the StructuresExtender class |

Name | Description | |
---|---|---|
![]() | CanExtend |
Specifies whether the current object can provide its extender properties to the specified object.
|
![]() | GetAttributeName |
Retrieves the AttributeName text associated with the specified control.
|
![]() | GetAttributeTypeName |
Retrieves the AttributeTypeName text associated with the specified control.
|
![]() | GetBindPropertyName |
Retrieves the BindPropertyName text associated with the specified control.
|
![]() | GetIsFilter |
Retrieves the IsFilter boolean value associated with the specified control.
|
![]() | SetAttributeName |
Associates AttributeName text with the specified control.
|
![]() | SetAttributeTypeName |
Associates the AttributeTypeName text with the specified control.
|
![]() | SetBindPropertyName |
Associates the BindPropertyName text with the specified control.
|
![]() | SetIsFilter |
Associates the IsFilter boolean value with the specified control.
|