API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

StructuresDialogFilterAttribute Class

The StructuresDialogFilterAttribute class specifies the attribute name for which the value of the attributed property will be used as a filter in Tekla Structures. The return type of the attributed property must be boolean. The apply and modify operations will only commit/update those attributes which either do not have a filter property defined or the value of the filter property is true.
Inheritance Hierarchy
SystemObject
  SystemAttribute
    Tekla.Structures.DialogStructuresDialogFilterAttribute

Namespace:  Tekla.Structures.Dialog
Assembly:  Tekla.Structures.Dialog (in Tekla.Structures.Dialog.dll) Version: 2023.0.1
Syntax
public sealed class StructuresDialogFilterAttribute : Attribute

The StructuresDialogFilterAttribute type exposes the following members.

Constructors
  NameDescription
Public methodStructuresDialogFilterAttribute
Initializes a new StructuresDialogFilterAttribute instance.
Top
Properties
  NameDescription
Public propertyAttributeName
Gets the attribute name of the property.
Top
Methods
  NameDescription
Public methodToString
Returns a string that represents the current StructuresDialogFilterAttribute object.
(Overrides ObjectToString.)
Top
See Also