API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

StructuresDialogAttribute Class

The StructuresDialogAttribute class specifies the attribute name to which the value of the property will be bound in Tekla Structures.
Inheritance Hierarchy
SystemObject
  SystemAttribute
    Tekla.Structures.DialogStructuresDialogAttribute

Namespace:  Tekla.Structures.Dialog
Assembly:  Tekla.Structures.Dialog (in Tekla.Structures.Dialog.dll) Version: 2023.0.1
Syntax
public sealed class StructuresDialogAttribute : Attribute

The StructuresDialogAttribute type exposes the following members.

Constructors
  NameDescription
Public methodStructuresDialogAttribute(String)
Initializes a new StructuresDialogAttribute instance.
Public methodStructuresDialogAttribute(String, String)
Initializes a new StructuresDialogAttribute instance.
Public methodStructuresDialogAttribute(String, Type)
Initializes a new StructuresDialogAttribute instance.
Top
Properties
  NameDescription
Public propertyAttributeName
Gets the attribute name of the property.
Public propertyAttributeType
Gets the attribute type of the property.
Top
Methods
  NameDescription
Public methodStatic memberGetCorrectDialogAttributeType
Initializes a new StructuresDialogAttribute instance.
Public methodToString
Returns a string that represents the current StructuresDialogAttribute object.
(Overrides ObjectToString.)
Top
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.